Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I broke my Mac Mini, trying set some permissions on some folders for web-development, but somehow ended up removing permissions from everything.

I managed to restore permissions, but have had a few issues since, namely the folder icons on the sidebar in Finder are not reflecting the icons they should be.

The desktop also seems slow to refresh when saving a file to it. They don't appear until I do another action.

Is this something I can fix in Terminal or elsewhere to restore everything back to how it was? Will I have to resort to reinstalling Mavericks?

Alternatively, will restoring from my Time Machine have an impact on things like these folder icons.

Default favorites icons


folder permissions when running ls -le as per answer below

 drwxrwxrwx@ 16 username  staff    544  5 Nov 21:33 Github
 -rw-r--r--@  1 username  staff      0  4 Nov 02:01 Icon?
 drwxr-xr-x@ 72 username  staff   2448  4 Nov 01:55 Library
 drwx---r-x@ 20 username  staff    680  4 Nov 01:44 Movies
 drwx---rw-@  9 username  staff    306  4 Nov 01:54 Music
 drwx---rw-@  8 username  staff    272  4 Nov 01:45 Pictures


share|improve this question
furthermore: I've created a new admin user, it also has the same issue. – ChelseaStats Nov 4 '13 at 21:12
this kept cropping up now and again for some reason. latest update to OSX fixed it. – ChelseaStats Apr 7 '14 at 10:17
I still think this bug is bizarre. Took me three months on and off to fix it on my mac. – Danger14 May 23 '14 at 16:47

How did you restore permissions? Manually, or did you use the "Repair" feature in Disk Utilities?

Restoring from a Time Machine backup from before things went bad should work.

One thing you might try before restoring is to delete the Finder preferences. ~/Library/Preferences/ then relaunch the Finder (Hold Option while selecting the Finder icon in the dock). The preference file will be regenerated with the system defaults.

share|improve this answer
I used the repair feature. this might be an issue, I don't have the file. – ChelseaStats Nov 4 '13 at 20:20
If you don't have a preference file, then things are certainly "not good" what did you do to your permissions? – sdmeyers Nov 4 '13 at 20:24
basically it looks like i removed my rights to access every folder/file under Home downwards. – ChelseaStats Nov 4 '13 at 20:26
being and idiot, found the file. deleted it. restarted finder. no change. – ChelseaStats Nov 4 '13 at 20:43
From the terminal could you let me know what you get when you type ls -le This should reveal ACLs which could be messed up or missing. One final trick, try dragging one of the folders directly to the sidebar, see what that does. – sdmeyers Nov 4 '13 at 21:36

You probably restored your preferences (not permissions) by deleting, right? You'll also want to take out one more file, which handles the sidebar, then reboot:

rm -rf ~/Library/Preferences/

It probably wouldn't hurt to Verify Permissions via Disk Utility either (since you mentioned them).

share|improve this answer
tried this, but made difference. thanks though – ChelseaStats Nov 11 '13 at 20:31

I had the same problem as you and it was because I had ACL's on my files in /home. If you have that problem (0: group:everyone deny write)

More info at

If permissions is not your issue, I've discovered an alternate solution which I posted here. Is it possible to change the Finder sidebar icons

share|improve this answer

reinstalled mavericks over the top and has cleared everything up.

having deleted the plist files in the other answers beforehand.


share|improve this answer
actually after later restarts and updates, problem has reappeared. – ChelseaStats Nov 11 '13 at 18:57
I had the same problem as you and it was because I had ACL's on my files in /home. If you have that problem (0: group:everyone deny write) go…. – Danger14 Dec 18 '13 at 20:25
you should put this as an answer @danger14 so i can upvote it – ChelseaStats Mar 13 '14 at 8:20
Thanks @TheCellarRoom. posted it. – Danger14 Mar 13 '14 at 15:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.