Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new iPad air wifi no cellular and set up iMessage but I cannot send messages to non iPad or iPhone users from Messages. It always tries to send the message but every time, it just stops and outputs that it has not been delivered. When I turn iMessage off every time I want to send a text message it asks to login. I can send messages on my iPhone to the same people that I want to message to using my iPad, with no problem.

share|improve this question
2  
iMessage is a service that allows you to send text message to other iDevice that has iMessage enabled. (iMessages aren't SMS). It has to be on the send messages from your iPad. – Matthieu Riegler Nov 4 '13 at 0:29
    
Vic, please grammar check your question before posting. We appreciate questions that are clear, concise, and eloquent. – AMomchilov Nov 4 '13 at 1:26

iMessage is actually an instant messaging service, like Google Talk or AOL Instant Messenger, except iMessage is made by Apple and is only for Apple products. Only an iPhone with cellular can send SMS messages as well, and can automatically associate phone numbers of registered iMessage users with iMessage accounts, so if you try to use the app to send a text to a phone number registered to an iPhone, it will send an iMessage instead. iPads cannot send SMS messages to non-Apple devices nor an iMessage to a phone number not registered with iMessage from a Wi-Fi-only device.

http://support.apple.com/kb/HT3529

share|improve this answer

Actually, you can send SMS from your iPad to anyone, just like your iPhone can text non-iPhone users. It's a complicated multistep process to set it up, but here goes:

  1. First, make sure you're signed into iMessage on your iPad in Settings > Messages > iMessage.

  2. Jump over to your iPhone and confirm you're signed into iMessage and iCloud with the same account here, too.

  3. Still on your iPhone, go to Settings > Messages > Text Message Forwarding.

  4. Inside Text Message Forwarding, flip the switches to enable sending text messages on one device at a time. Then look at that device – you'll see a confirmation number that you'll have to enter on your iPhone. This ensures you've got physical access to both devices at the time you're setting it up.

  5. Confirm the link by typing the code and you're finished!

Sources:

share|improve this answer

iMessage sends the message through Apple to the intended recipient. Because the iPad is WiFi without cellular [data], SIM cards cannot be inserted and therefore the iPad is not able to message non-Apple users. As noted, 'only sim-cards have access to the GSM network to send SMS messages'.

Update: You can now send text messages through your iPad if you have an iPhone. (See here.)

share|improve this answer
1  
There is no need to embolden the not's, and the tone of this is condescending. Try to be more factual, and helpful. It may be more useful to mention that only sim-cards have access to the gsm netwrok to send SMS messages – wrossmck Feb 19 '14 at 23:08
    
Well I forgot that I had this answer. Oops. Thanks @wrossmck – Brick Jun 1 at 10:41

After 3 visits to an Apple store Genius Bar, I was finally informed that Ipad Air messaging only works when sending or receiving text messages with other apple products. This, in my opinion, makes it essentially useless. Since most of my messaging contacts do not have apple products, I turned off my iPad Air messaging and simply use my iPhone for all of my text messaging. I consider this to be a design flaw in iPad Air which will hopefully be recognized and corrected sometime in the near future.

share|improve this answer
    
There are apps to bridge the gap. Try WhatsApp for one or Simple SMS or Real SMS or any of the dozens of SMS apps for iPad on the store. – bmike Mar 5 '14 at 0:22

protected by Community Mar 19 '14 at 6:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.