Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to allow the _www group to write to a folder.

I clicked on the folder to go to the "Get Info".

At the bottom there is a "Sharing & Permissions" section with a "+" to add users. However it does not show any of the system groups such as _www.

Is there a way to enable showing hidden users and group in the GUI? Or do I have to do it via command-line instead? It seems the GUI allows to set permissions for several users and group, which I like, while the command I believe only allow 1 owner and 1 group?

share|improve this question
+1 because you made me sit down and figure out why Apple left out the standard commands and what to do about it. – geekosaur Mar 24 '11 at 19:59
up vote 5 down vote accepted

Apple hides anything it considers a "system" user or group from the GUI. There's probably some way to disable that, but I generally use the command line for system-related stuff.

The command line version comes in two flavors: there is a basic permissions structure with a single owner, a singe group, and everyone else, then there are POSIX ACLs. Interestingly, Apple took the route of modifying chmod to support ACLs instead of shipping the standard getfacl and setfacl tools.

$ sudo chmod +a 'group:_www allow add_file,add_subdirectory,list,search,delete_child' /webroot

You may also want the file_inherit and directory_inherit permissions to apply the ACL to created files/directories. See chmod(1) for more details.

The -a option to chmod removes ACL entries.

share|improve this answer
+1 just a small clarification, do you know if/why sudo chmod -R +a '<permissions>' /webroot will give permissions to all subfolders, but not to webroot folder itself? because that's what happened when i tried it. – May 12 '12 at 5:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.