Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently got Keynote 6.0 and I'm having trouble animating a gif in it. Using Insert > Choose... easily adds the gif to the slide, but without animation. I have searched and found other sources (example) which all seem to point to using the "Quicktime Inspector" to work with the animation of a gif. Unfortunately, the Quicktime Inspector no longer seems to exist in version 6.0 and I can't seem to find the solution otherwise. Any suggestions? Thank you much!

share|improve this question
1  
Keynote 6.2 added support for animated GIFs. –  mislav Apr 1 at 21:39
    
@mislav: If you want to add that as an answer, I'll accept it. –  golmschenk Apr 3 at 22:48

6 Answers 6

If you change the extension to .mov then drag it over, it’ll ask you to optimize for iOS, at which point it will treat the GIF as a movie.

share|improve this answer
    
This works only if you have the .mov file (and not just by changing the animated gif extension) –  Alex Popescu Dec 17 '13 at 4:10
    
@AlexPopescu Seems to work for me. Just tried using a simple mv lol.gif lol.mov and then dragging the file to Keynote 6. –  Mathias Bynens Feb 25 at 13:06
2  
This worked for me twice in a row just now, and I was happy, and then 4 other .gifs did not work. Keynote gives an error: "Media could not be inserted." Apparently it only works for certain types of GIFs but I have no idea what the qualifications are. –  rhodesjason Mar 14 at 21:37

In my experience, animated GIFs (and Flash animations) are no longer supported in Keynote. You would probably have to use ffmpeg or QTPro to convert the GIFs to movie files and re-import them.

share|improve this answer
up vote 2 down vote accepted

The problem was fixed in Keynote v6.2. Update Keynote and it should work. (as mislav informed me in the comments)

share|improve this answer

They won't animate until you view the slideshow, but should there. Also, go to the Inspector>Quicktime Tab and make sure to change the Repeat setting from None to Looping.

share|improve this answer
    
Thanks for the response. However, I did mention in the question that in the new version of Keynote, the Quicktime Inspector doesn't seem to exist any longer. Also, it doesn't seem that the GIF is animated even in the slideshow (in the new version of keynote). –  golmschenk Nov 12 '13 at 23:17

The new Keynote (v6) doesn't import GIFs in like it used to, which is disappointing.

However, if you open an old Keynote presentation (Keynote '09), Keynote v6 will ask you if you want to update and/or optimize it for iOS devices. If you optimize, it will render the animated GIF into .m4v. Once that is done, if the Format inspection, you will have a "Movie" tab.

The down side is that you MUST have Keynote '09. I tried to export an animated GIF created in Keynote v6 as Keynote '09. It did not maintain the animated GIF correctly, so when I reopened it, I did not get the "Optimize" option

share|improve this answer

if you want a GIF to repeat itself, as beroe correctly pointed out, save the .gif to some folder, change it's file extension (make sure to show the real extension and not hide it (cmd+'i' is the canonical version, change it there if you're unsure)) to .mov and then drag it to keynote 6. Optimize for iOS and now select "endless" in the "format->Film" section under "repeat" (I don't know the correct translations as I use a german keynote).

share|improve this answer

protected by Community Jan 28 at 14:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.