Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After I've update my OS to Mavericks.

Terminal goes really slow, I've found out that the problem must be from Xcode.

While I remove Xcode from my computer terminal works fine, and after I installed Xcode, it goes slow again.(It takes like 2 second for ls command)

Please help.

PS. my computer is MacBook Pro with Retina.

share|improve this question
1  
Are you using ZSH and the vi-mode plugin? github.com/robbyrussell/oh-my-zsh/issues/2189 –  Adam Albrecht Nov 1 '13 at 3:24
    
yeah, I've solve the problem after reset my .zshrc. thanks –  LiJung Nov 1 '13 at 5:22

1 Answer 1

up vote 1 down vote accepted

I had the same problem to and I was looking for the way to solve it.

Checking at the issue that Adam Albrecht commented, it looks like the problem was being caused by the zsh vi-mode plugin in combination with the apple provided git.

Installing git from homebrew solve the problem without having to deactivate the vi-mode plugin

share|improve this answer
    
I've just solved it after reset my .zshrc. thanks! –  LiJung Nov 1 '13 at 5:22
    
Excellent answer! The update apparently mixed up my path so the system git was before brew git. Now everything works again. Thanks! –  Tigraine Nov 12 '13 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.