Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have broken my issue into several parts hoping to make it easier to understand what I am trying to accomplish as well as what I have tried. Any suggestions/advice would be greatly appreciated!

The Goal

Install and boot Windows 7 Professional on a new Wintec 48G SSD via Expresscard 34 slot.Can this be done, if so has it been done before?

Background

The rationale behind installing Windows on the SSD is that I do not plan on using it often (need to run Win-only software at times). With this being said, I have heartburn slicing off a 32 gig partition of my main HDD to install Windows on and not be used but once every 2-3 weeks. If I can get it installed on the Wintec, in theory, I could remove it when not in use to save battery life and leave the port open for other devices. It is worth noting that I plan on storing all important data on the internal HDD based on several reviews of the Wintec.

In the past, I have run virtual machines, but handful of the USB devices I use for work have not worked well (if at all). Also when running a VM, the speed of both the VM and OSX is greatly reduced including a crippled battery life. Because of these experiences, I am trying to stay clear of virtual machines for this particular build. On a side note on the virtual machines, I have seen a few examples of running a bootcamp partition using open source VM software. This would be the approach I would take if I went back to a VM.

While scouring the web, I have found lots of examples that the Wintec 48 gig is bootable with OSX (with much success from the looks of it). Over all, the most common way that I have seen to accomplish this is to use disk cloning software. This method works great for OSX, but I do not believe that it can be applied to the Windows 7 install.

I have managed to boot from / run the Windows 7 installer for both 64bit and 32bit versions. On both installers I have made it to the point of selecting the HDD to install to and receive an error message stating that the system cannot boot from this device (Wintec) and to check the BIOS settings. This makes perfect sense on a normal PC, but with the Mac not having a BIOS I have run out of ideas.

While trying to fix this problem, I have tried formatting the SSD in NTFS 3G, NTFS Compressed, NTFS, FAT-32 and unused space. The hope was to format the drive using Disk Utility and have the Windows Installer format it to what Win 7 required. After approximately 6 hours of testing, I have concluded that it was a losing battle and begun reaching out to the communities for help.

System Information

Hardware: MacBookPro4,1 (2008 non-unibody), 4G RAM, Expresscard 34 Wintec 48G SSD Software: Running OSX 10.6.6. Wish to install Windows 7 Pro (64 bit preferred)

share|improve this question
1  
i am trying to attempt this too.. i am on macbook pro 5,2. i had hard time installing snow leopard on Wintec ExpressCard 96GB. installation would fail now matter how i tried to install it either via usb or dvd. finally i had to install SL on my internal HD first and then restore it to Wintec even then it would fail, saying cannot allocate memory.... diskwarrior to rescue which fixed b-tree nods. I want to install Windows XP on it since i have Onda VX545HD PMP player which only recognized by XP. So maybe there is way to restore windows partition to wintec after installed on internal HD? I am no –  user6788 May 27 '11 at 11:39
1  
I have had the Wintec Engineering group looking into this and after a few weeks they came back and said it was not possible. I will try and get their exact wording up here as soon as possible. (It is on a my very long list of TODOs). –  Adam Lewis May 27 '11 at 14:09
    
Welcome to the community. Stackexchange is not like other forums. Answers to questions should actually attempt to answer the question. Otherwise, remarks such as this should be entered as a comment. I am going to convert your answer to a comment for the question itself. Cheers –  Philip Regan Jul 11 '11 at 9:55
    
@Philip- I'm not quite sure why this would be a comment and not an answer... The product manufacture said it was not possible. If I were looking for this information again I would like to see it as an answer (it would stand out). I'm a heavy user of Stack Overflow and understand that posts can be modified by others, but at least post a comment and give someone a chance to understand why you are going to do something before doing it. Cheers –  Adam Lewis Jul 11 '11 at 13:39
    
@Adam Lewis: I'll admit I was a bit hasty in converting your answer. It was flagged by someone else as not an answer, which in retrospect I don't entirely agree with. But I will say that your answer will be a better one once you get the aforementioned text to make the answer complete. If you post it, I will vote it up. Sorry about that. Cheers –  Philip Regan Jul 11 '11 at 14:09

3 Answers 3

I use Parallels to run Windows on my MacBook Pro 5,1

I boot from my SSD 64GB and have my Parallels image on the SSD.

It runs super fast! It takes 14 seconds to boot up Win 7.

share|improve this answer

this might help you for a start? I've got the same problem right now, but using 96GB version of that card.

edit: http://forums.macnn.com/104/alternative-operating-systems/397685/windows-7-on-expresscard-ssd/

share|improve this answer
    
Thanks for the link. This just happens to be a link that I did not find with Google :) I will look into this tonight to see if I can get the USB install to work. On a side note, I have this exact question on several forums and will update all of them if/when I find a solution. –  Adam Lewis Mar 23 '11 at 12:02

Have been working on this for weeks. It appears the computer will not recognize the SSD at all when booted into Windows. I have installed Win 7 on another partition on the internal drive, booted, gotten it to recognize and use the SSD as an external drive. If I install it in the 34 slot, it never shows up. Plugged into USB, it shows and can be used, but cannot be installed to. I tried downloading drivers from Wintec, but the "drivers" that I downloaded are not the right thing at all (even though that is where the site takes me), but instead are for some kind of RAID setup having nothing to do with the SSD.

Next step is to try finding a firmware update from Apple. Apparently there is a problem common to ALL 34 slot devices on the MPB not being recognized in Win 7 at least. Even if I can get it to recognize it, though, there is no guarantee that I can install Win 7. If I clone it, I can get it to appear bootable, but that ends up taking me to an OS missing error.

I'll try to update if I make a breakthrough.

share|improve this answer
    
Well it's good to know that there is someone else in the same boat as me :). I have placed a ticket in Wintec's support system and their engineers have already sent one round of attempts my way. They were not successful, but I hope to hear back from them again. My current direction to get this working is to use Parallels 6 to install Win 7 and cross my fingers that I can boot from it. Their forums show small victories on installing Win 7 on external drives. I will update this forum with any success. –  Adam Lewis Mar 29 '11 at 5:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.