Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since Safari 7.0 which was introduced yesterday with OS X Mavericks the little terminal hack

defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

doesn't work anymore (at least not for me).

Once you use the Terminal hack, the PDF is shown in binary/ascii-format in a new tab of Safari (like if you would open the file with TextEdit instead of an arbitrary PDF reader):

content of pdf in safari

Any suggestions how to achieve the desired behavior anyway?

share|improve this question

3 Answers 3

Just adding support to find an answer to this issue. I suppose in the meantime do this:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO
share|improve this answer

Holding ⌥ alt/option down while clicking it makes it download it. That is with the old hack still marked YES. Not the best solution, but will do for the time being.

share|improve this answer

For Me this was not enough. I had do de following:

  1. Type in Terminal.app:

    defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES
    

    This disables pdf support in Safari.

  2. Restart Safari

  3. Type in Terminal app:

    defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO
    

    This enables pdf support in Safari.

  4. Restart Safari and reload pdf page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.