Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After I updated to Mavericks, the font smoothing is terrible, tried playing with the setting in system preferences (didn't restart yet) and nothing changed.

I have a 15 inch early 2011 Macbook Pro with high resolution anti-glare screen (not retina)

Here's a sample: enter image description here

Here's Finder menu bar in Mountain Lion

ML

vs Mavericks

MV

In this example you see that the left of "F" in "File" is noticeably fuzzier in Mavericks.

The problem is all over: window bars, menu bars, web pages (Chrome & Safari), apps, etc.

share|improve this question
    
Can you elaborate a little ? Looking at your pic at 1:1, this looks good to me. There is sub pixel antialiasing everywhere, and I don't see anything unusual. –  Antoine Lecaille Oct 24 '13 at 7:33
    
It drives me crazy. It is too smooth. Look at the "F" from File, the left side is blurry (too much smoothing). It used to look very sharp on my Mac before. Here's more details on the same font, same browser (Chrome), after & before: cl.ly/image/0q1n3u2I063q After (1st image) looks more fat, more clumpy and hard to look at. 2nd one looks nice and crisp. –  Cristian Oct 24 '13 at 7:49
    
The only thing I notice is that the colour of the menu bar is kinda blueish. Can you test with a pure black backgrounds on you desktop? Can you provide a screenshot of the exact same element (F letter in the menu bar) with the same desktop background on your Mac before upgrading if you happen to have kept 10.8 ? The problem is that colour perception is subjective, so it's sometimes impossible to express it with words. –  Antoine Lecaille Oct 24 '13 at 8:13
    
Also, there is NO sub pixel antialiasing on the text in the menu bar, neither in 10.8 nor in 10.9, but this is normal behaviour I guess. Use DigitalColor Meter app to have a good look at this. –  Antoine Lecaille Oct 24 '13 at 8:16
2  
I have the same exact system and the same exact problem. Here are the screenshots of Finder menu bar, with translucency turned off on Mountain Lion !ML and on Mavericks !MV The letter "F" in "File" is definitely blurrier on the left side when rendered in Mavericks. This is not an answer but I was unable to leave a comment because I don't have enough reputation yet - my apologies. –  gooogalizer Oct 26 '13 at 15:57
show 3 more comments

4 Answers

up vote 8 down vote accepted

The system font was changed to a modified version of Lucida Grande. It was mentioned in the What's New in Cocoa presentation:

The normal Lucida Grande doesn't seem to have changed:

There is still this hidden preference for using a lighter text rendering style:

defaults write -g AppleFontSmoothing -int 1

Quit and reopen applications or log out and back in to apply the changes.

The regular faces of the new and old versions don't look that different, but the bold face seems to be bolder in the new version.

The screenshots posted by gooogalizer have bigger differences though, so maybe the new version is rendered in a different way on high-resolution displays, or maybe something else changed in the way text is rendered on high-resolution displays.

share|improve this answer
1  
The problem is that there is sub pixel AA in all of your examples, except for the text light/default - but I presume that you did this in Photoshop or something, so that's expected. But some screenshots provided in the question miss sub pixel AA. –  Antoine Lecaille Oct 27 '13 at 12:27
4  
@AntoineLecaille You're right. You could also try running defaults write -g AppleFontSmoothing -int 2. In 10.6 subpixel rendering was disabled by default on some non-Apple LCDs, but running that command enabled it. (See 10.6: Re-enable LCD font smoothing for some monitors - Mac OS X Hints.) –  Lauri Ranta Oct 27 '13 at 13:13
add comment

What this means is that Apple plans to produce all of their upcoming products with retina-displays within 6 months. Mavericks is made for this feature. I updated to Mavericks as well on my new Air and it looks fuzzy. It's not fun. I suppose that'll force me to upgrade to a new one in less than a year if I want't to be able to save my eyes.

share|improve this answer
    
I'm afraid to be right, but I think this is the real answer. I also suspect it has to do with an internal decision to make new macs look prettier at the expense of old macs looking uglier. I wanted to see if it was only on my mac or other macs as well. My colleagues didn't notice the different, but then I'm the only one who had a bit better resolution, and I could see the difference. –  Cristian Oct 29 '13 at 9:05
add comment

This solution worked for me:

  1. Download the patch-edid.rb script from the forums thread above and put it in your home directory.
  2. Connect only the external monitor(s) in question (I closed my MacBook lid, for example). The script will make override files for any connected monitor.
  3. Type ruby patch-edid.rb in Terminal.
  4. A new folder will be created in your home directory. Move it into the /System/Library/Displays/Overrides folder. If Finder tells you that you are overwriting an existing folder, consider backing it up first.
  5. Restart your computer, enjoy your monitor.

After applying the script with edits the EDID info for the monitor, also calibrate it and the fonts should look much better (at least in OS X menus and Safari). Chrome still renders bold fonts differently.

share|improve this answer
    
Welcome to Ask Different! While the link you provided may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. I've edited your question to include what I believe was the solution that you were referring to, however if it wasn't please quote the relevant section. –  grgarside Nov 3 '13 at 16:59
add comment

I have this same issue. The lighter text rendering command does help a little but not sure if it stays after a reboot?

The break-through for me has been switching browsers. I now use Google chrome for most of my browsing.

Both text and graphics look much sharper - when comparing some sites the difference is enormous.

share|improve this answer
    
Switching browsers only helps for just that - browsing the web. The rest of the OS would still have incorrect font smoothing. –  Andrew Larsson Mar 9 at 21:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.