Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I search for stuff, even constraining with name:whatIwant, the majority of results are old e-mail messages and Safari history items.

How can I get rid of these results, but still search my email from within the Mail program? I have already added the History folder from Safari to the Privacy tab and put the Mail app in there too, but the results still show.

I am using Mountain Lion at the moment.

EDIT: It turns out I already had Messages and Web history un-selected in my Search Results tab (see second screengrab below), but I am still seeing the results from Web pages and from current (not just archived) Mail messages.

My Spotlight privacy tab:

spotlight privacy

My Spotlight check boxes...


Some results from my search window:

Search results

share|improve this question
I will try the Messages suggestion, but any ideas about the History folder too? I added the folder location directly from the search results window. – beroe Oct 20 '13 at 16:56
up vote 1 down vote accepted

I have struggled with this also (telling spotlight NOT to search in mail etc.)... The best solution for me so far has been to get in the habit of writing:


at the end of every search I make in spotlight.

I will admit this isn't a GREAT solution - but it works (and you could probably set a keyboard shortcut to type it for you if you wanted).

share|improve this answer

In System Preferences -> Spotlight, go to the Search Results tab, and uncheck Messages and Chats.

This will still allow you to index and search from within Mail, but the results will not show up when searching via Spotlight.

share|improve this answer
Did you get a chance to test this? It is the same as the earlier answer, so has credibility of the masses, but didn't work for me. Wondering if it is because I have something weird in my set-up or if it isn't actually correct... – beroe Oct 20 '13 at 17:25
Darn... Please wait until Oct 22 and then try my unedited answer on Mavericks. – Alan Shutko Oct 21 '13 at 2:27
Yes, a lot of our problems may be obsolete or different soon. We'll see. – beroe Oct 21 '13 at 6:04

You can add ~/Library/Mail/ to the privacy tab, but it also prevents you from searching for messages in Mail.

If you can consider using Alfred instead, it doesn't include mail messages in the default search results, and it can be configured to not show mail messages even when you use the open or find actions.

share|improve this answer
  1. Start Spotlight (by default ⌘ cmd+space) and search for any term, then select Spotlight Preferences… at the bottom of the list.

    Alternatively, open System Preferences and select the Spotlight pane.

  2. Uncheck "Messages & Chats" and close System Preferences.

share|improve this answer
Stop Down-Voting my Answers, Mike. Get a Life! – TechAndNews Oct 20 '13 at 15:53
perhaps you should get the answers right instead of complaining about votes? Messages and Chats controls display of iMessages and chat logs, not mail. – Alan Shutko Oct 20 '13 at 16:22
Messages and Chats does control iMessages and chat logs but also Mail messages. – Daniel Oct 20 '13 at 16:38
You'll have to look elsewhere for someone who down-voted your initial version of this post. I did cast one down vote on one of your posts earlier today - but I did comment exactly why I thought it was not useful. The best place to work out how voting happens is on Ask Different Meta if you worry that someone (even a moderator) would target votes to you. – bmike Oct 20 '13 at 16:40
@TechAndNews. Thanks for the answer. I don't know who/why the downvote occurred, but looking at your original post, I think it could have been because (1) it sounded at first like you are telling me how to do a Spotlight search (rather than an easy way to get to the Prefs) or (2) because you had a bit of an infomercial at the end of your answer. Don't worry, my upvote makes you net-positive, although it doesn't seem to solve my problem. – beroe Oct 20 '13 at 17:23

For me the issue was that my email account was set to automatically download all attachments. Go to mail->preferences->accounts->(click on an account)->advanced->uncheck "automatically download all attachments"

After doing this you might have to remove and add your account for mail

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.