Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I VPN into my work Windows PC (Win7) and used to use MS RDC to access it, but a little while ago a network move at work led to RDC no longer working.

The RDP connection via CoRD still works fine. On attempting to connect with Microsoft RDC 2.1 or 2.0.1, I get 2 error dialogs now. The first complains "The certificate is not from a trusted certification authority", whilst the second says that "The remote computer is not allowing connections from the Mac". Eeven though I have set the remote computer in question up to allow RDP, as evidenced by my ability to access it via CoRD.

I can still access other PCs on the same work network using RDC, just not the one I want to use. I'd prefer to use RDC over CoRD simply because it is faster on my 10.6.8 MacBook Pro.

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

I had something similar happen to me once. What I did was to go into the Preferences for RDC, and in the Login tab, remove the value for the Domain parameter. That did the trick for me.

share|improve this answer
    
That wasn't quite it, but it gave me enough of a clue to find the solution. Turns out I just needed to change Remote Computer Authentication in the Security prefs pane to 'Always connect, even if authentication fails' and I'm able to connect again. Dunno why I never thought to have a rummage round the prefs dialog! –  Ewen Cartwright Mar 21 '11 at 21:20
add comment

Had the same problem too. In Preferences, Login, I had checkbox "Automatically reconnect" ticked, and it tried to connect with wrong credentials.

Either remove tick, or make sure you have the right username and password.

share|improve this answer
add comment

Actually, in my case, RDC password was stored in the keychain on Mac. I deleted the keychain entries, closed out RDC completely (Apple --> Quit) and restarted it. This time it prompted me for a password (and saved it correctly in keychain once again) and logged me in.

"Automatically reconnect" is a feature which you do not want to disable generally.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.