Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have MacBook Pro with a Mini DisplayPort to HDMI Adapter. I use the adapter to play images from the Mac to my Sony Bravia TV.

Since it doesn't play sound, I have an audio that connects the Mac to the PC in HDMI Audio jack.

Even though, the sound still doesn't play on the TV (and when the cable is connected to the Mac, the sound also doesn't play on the Mac, which indicates the sound is going somewhere else, but not the TV!).

I've tried some configurations on the Applications / Utilities / Audio Midi Setup, but nothing works!

What should I do? Any idea on how to make the audio cable work?

share|improve this question
    
I have this problem, only with a Mac Mini 3,1 2.26Ghz and a sony bravia TV and a newer technology adaptor. RCA to headphones don't work either. Neither appears in sound control panel. –  Sam Katz Jan 11 '12 at 19:31
add comment

3 Answers

Some thoughts, and things for you to check on:

  • What model of MacBook Pro do you have? Older ones (pre-Mid 2010) don't have audio out through the Mini DisplayPort.

  • Have you tried looking at System Preferences » Sound » Output? What devices are displayed, and what have you chosen?

  • Can you explain what "I have an audio that connects the Mac to the PC in HDMI Audio jack" means?

  • Which Mini DisplayPort to HDMI adapter do you have? The early models were made to work with the then-current MacBooks (and Pros)—and as those models didn't have audio out over Mini DisplayPort, there wasn't any reason for the cable to, either.

  • Have you tried hooking up a cable from the Mac's audio out/speaker jack directly into the TV?

  • Some possibly-helpful info:
share|improve this answer
add comment

I came up with a workaround for this today. You can use an headphone-->rca cable. You can plug it in, or possibly the newer technology audio hdmi adaptor that combines the two into the headphone jack, and then into rca.

The trick is you then need to tell the TV that while you are using the HDMI for video, you need it to use a different input for audio. (in my case video 2). In the case of my Panasonic TV Menu-->Audio-->Advanced Audio, and then arrow down to the hdmi video input you're using and then arrow to the side to make a different selection.

share|improve this answer
add comment

Had the same problem with 2 different adapters. Finally I went to System Preferences » Sound » Output and selected HDMI (I had options of Internal Speaker and LG TV(HDMI)).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.