Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't think I've used x11 since switching to Mountain Lion (and thus Xquartz). I recently tried to use it and my key repeat isn't working. When I press a key, it inserts the corresponding character once, then a second time after (very roughly) a quarter second, then never repeats again. I've tried xset r and xset r on from both my x11 terminal, and normal Terminal.app --- neither has any effect.

Any suggestions?

share|improve this question
up vote 1 down vote accepted

From @jaykru on SuperUser.SO (http://superuser.com/a/414513/152522):

Did some more searching and discovered in recent updates the key repeat rate for x in OS X is set at some odd value. Anyway, to whoever else may have this issue, run this in your shell:

    xset r rate <milliseconds_before_repeat> <repeats_per_second>

Or just xset r rate to reset the keyboard repeat rate to default X settings (i.e: something sane.)

share|improve this answer
    
i can't get xinitrc to not choke on xset's. – Wyatt8740 Apr 25 '15 at 20:46
    
Where should I put this setting? – user8823741 Nov 28 '15 at 12:40
    
@mcb you run it in the terminal – DilithiumMatrix Nov 28 '15 at 17:37
    
@DilithiumMatrix: Every time? Is there no way to have this set automatically? – user8823741 Nov 28 '15 at 22:16
    
@mcb That sets the default value. – DilithiumMatrix Nov 28 '15 at 23:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.