Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On iOS 7, there is a feature under Cellular in Settings called: Use Cellular Data For:. This lists all of the apps I have on my iPhone 4 with individual On/Off Switches to disable or enable cellular data. So, I disable it on several of my apps, one of which being Music. When I open my Music app, it tells me…

Cellular Data is Turned Off for "Music"
You can turn on cellular data for this app in Settings.

This alert does not occur once, but every time I clear the Music app from my multitasking and re-open it. Is there a way to dismiss this alert once and forever?

The alert looks something like this, but for Music:

share|improve this question

2 Answers 2

up vote 7 down vote accepted
+50

This can't be done at the moment. There's no option to disable the alert, other than enabling cellular data.

If you're jailbroken, you can install NoAnnoyance:

NoAnnoyance

Tame iOS annoying alerts!

A CydiaSubstrate tweak to disable annoying iOS 7 messages.

Supported alerts:

  • Cellular data is not enabled
  • Disable airplane mode to access data
  • Turn Off Airplane Mode or Use Wi-Fi to Access Data
  • Location accuracy improved by enabling Wi-Fi
  • Unsupported charging accessory
  • Accessory unreliable
  • Low battery
  • Cellular data is turned off for "AppName" disabled
  • Low disk space
  • The mail server is not responding
  • More...

If you wish for a non-jailbreak solution, you can provide feedback to Apple regarding this at the following page:


Possible solution provided by Parasprite — I can't get it to work:

After some trial and error, it seems as if it becomes permanent after a few tries.

  1. Turn cellular data off for the offending app ([Music]).
  2. Open [Music], dismiss warning.
  3. Close app using the app switcher (double-click home button and swipe off of screen).
  4. Re-open [Music], dismiss popup.
  5. Goto step 3, repeat until it stops showing.

If it's behaviour is anything like The Game Center popup, it should be permanent after 3 dismissals.

share|improve this answer
    
Thank you for your edit. Jailbreaking seems to be the only available solution as of now. –  sameetandpotatoes Mar 1 at 21:02
    
Are there any updates on this question? I don't want to Jailbreak my iphone but I can't stand these messages! –  user4050 Aug 27 at 19:06
    
@user4050 AFAIK nothing's changed and nothing appears to have changed in the iOS 8 betas regarding this –  grgarside Aug 27 at 19:08

If the popup only occurs after you clear Music from your multitasking, you could simply avoid doing that.

I know I can't convince inveterate app quitters, but the multitasking on iOS really does all the handling of RAM just fine.

share|improve this answer
    
While this would help users with an iPhone 5 or 5S (even a 4S), my iPhone 4 becomes slow after 5 or more applications in multitasking, which means this would not be my first answer choice. Thank you for your answer. –  sameetandpotatoes Apr 13 at 16:36

protected by Community Oct 26 '13 at 14:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.