Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Before being forced to upgrade iTunes I originally had my music library set up so that I had all the songs listed, ordered and group by album and I could see their cover art, this made things easier as some of the albums I have are OST with multiple artists so I can easily find all the songs of an album and make it int a compilation, I was also at the time adding cover art to every album since most music off CDs are devoid of this

However after upgrading I can't do this, the songs section doesn't show the cover art and nothing is grouped like it was, the albums section has the cover art however everything is ordered by artist which is crap cause now I'm getting Mugen Souls, Darker than Black, Spice and Wolf and Puela Magi Madoka Magica all appearing before Accel World, also I don't see a track list unless I click on an album, also it appears I can't sort it

I was in the process of reorganizing my entire library and I can't revert back to a previous version of iTunes as I have to have version 11.1 because iOS 7 refuses to even allow the device to connect (thus why I had to upgrade, I would have if given the choice), so, how can I get iTunes 11.1 to shows a list of songs, sorted and grouped by album and showing the cover art

NOTE: I can't connect to the Internet

share|improve this question

1 Answer 1

up vote 2 down vote accepted

figured it out, it could be that i did this in the old itunes and because it was years ago i forgot and that updating itunes reset every setting

anyway, here are the steps i followed

  1. click on the icon in the top left hand corner and select show menu bar (or Ctrl + B)
  2. click on View > Show View Options (or Ctrl + J (you may be able to skip step 1 but i didn't use shortcuts))
  3. Make sure Sort By is set to Album
  4. Click in the checkbox beside Show Artwork
  5. make sure that under the Music Section that the checkbox beside Album is checked, if it is not the albums will not be sorted alphabetically like they really should, while you can sort by what ever way want sorting by name will split albums and you'll only see the groups if 2 or more in the list have belong to the same album (ie. Check Mate and Cheese from Code Geass Lelouch of the Rebellion R2 - OST 2 will appear grouped and before Chemical Magical Cooking from Dream Eater Merry Character Songs - Kounagi Yui but separated from Guren which belong to the same sountrack)

Optional Parts (stuff i did because i like it)

  1. Check in the checkbox beside Always Show - unless the size of the list of songs in an album group is greater than or equal to the height of the artwork it wont show, i would say 7 songs cause alot of Opening Soundtracks i have have only 4 tracks, with Always Show checked the list of songs in an album has 3 spots left
  2. Set the Artwork Size slider to max (may have an affect to what i have explained above)

EDIT: these steps also work up to 12.0.1.26. Though when I installed it the default view for music was Albums. When you do step 2 make sure the view is set the view to Songs otherwise the options from Step 3 onward will not appear

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.