Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am new to Mac. I installed emacs, but I can't see my .emacs file in the finder. I can open the file from inside emacs, and I saved another copy on my desktop, but it's not showing.

share|improve this question
    
Do you need to see these files in the Finder or in terminal? –  AllInOne Sep 26 '13 at 21:24
    
I just want easy access to my .emacs file so I can make backup copies. And after I made a copy, I would like being able see it so I know where it is. –  LWZ Sep 26 '13 at 21:58

1 Answer 1

up vote 5 down vote accepted

These files starting with a dot are meant to be hidden in *nix.

To see them in terminal add the -a flag to the ls command:

ls -a

To see them in the Finder you will want to set a hidden preference (this is global change tho, you'll see all your hidden files everywhere):

defaults write com.apple.Finder AppleShowAllFiles TRUE

and then restart the finder:

killall Finder

To reverse and hide them again:

defaults write com.apple.Finder AppleShowAllFiles FALSE && killall Finder

Source

Update to add:

Lately I've only been able to get this to work when the string com.apple.finder is lower case! I think this happened starting in 10.9, but not certain.

So you'll want:

defaults write com.apple.finder AppleShowAllFiles TRUE;
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.