Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I keep my iPhone on silent pretty much all the time. When I plug it in to a charger, it goes "buzz-buzz". My iPad doesn't do this. Both behaviors are the same with iOS 6 and 7.

How do I make my phone not do that?

I have checked the activity-specific sound settings (like Lock Sounds [off], etc). The main suspicious ones are Vibrate on ring and vibrate on silent. I would still like to have it buzz (vibrate) upon receiving texts, calls, and calendar alerts.

share|improve this question
    
I would love to be able to do this, because if I forget and leave my iPhone plugged into the Mac at night, the Mac comes up to a semi-sleep several times in the night, USB power comes on and BRRRRT BRRRRT - the phone wakes me up. Super stupid that such a "feature" can't be disabled. – Steve May 23 at 3:57
up vote 4 down vote accepted

There is no way to natively disable this other than turning off vibrations completely. Only your iPhone does this because the iPad (and the iPod touch) don't have vibrate motors.

If you jailbreak, there is a tweak called PowerSoundDisabler. It's a simple tweak to disable sound and vibration when respringing or plugging in via USB.

share|improve this answer
5  
Even if you turn off vibrations completely there will be vibration when you plug your phone to a charger. – bessarabov Apr 16 '14 at 13:22
1  
@bessarabov I can confirm that. It is slightly annoying I you find yourself in school library, where every sound matters. – quapka May 20 '14 at 9:08

Plug in your head phones into the phone, turn off silent mode and turn your headphones volume down.

You may also want to turn off vibrations in sounds then charge your phone! It will make no vibrations and if you put it back on mute, your phone won't vibrate as well :)

share|improve this answer
    
Clever, if inconvenient. – beroe May 22 '14 at 6:59
    
Why turning off silent mode? – Cesare Mar 14 '15 at 21:56
    
I couldn't get this to work, and other comments on this page suggest that this is impossible. Please elaborate on instructions if this really does work. – JDiMatteo Jul 2 '15 at 16:19
    
This works. I'm running iOS 8.4 on an iPhone 5 - I turned my headphone volume down to mute in case that matters. I also have all settings in Sounds to silent. To deal with the inconvenience of the cord I used an old old auxiliary cable, cut the cord, and then plugged that in. – kraftydevil Apr 14 at 15:21
  1. Update to iOS 9.
  2. Go to Settings, Sounds, Vibrate on Silent and deactivate it.
share|improve this answer

To do this you will have to Jailbreak your phone.

share|improve this answer
3  
Might you be able to expand on this with a link to the mod that works with iOS 7 (or at least iOS 6) in case someone wants to try this? – bmike Sep 26 '13 at 16:38
    
Might I also point out that I already addressed that in my post, with a link to a specific tweak... – daviesgeek May 20 '14 at 16:32

protected by Community Sep 17 '14 at 12:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.