Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My Mac has everyone in the families music on it. We have a playlist each that we sync to our various devices.

Since iOS7, all the music I've ever purchased from iTunes is now on my phone, not just my single playlist.

That wouldn't be so bad if the purchased music wasn't dominated by all the rubbish that I've bought for my kids.

I think it's just streaming, but it's still really annoying because my car shuffles between all the songs on the device by default.

Edit: Daryl's suggestion to turn off "Show All Music" in Settings got rid of all the purchased songs I hadn't played. Ones I was foolish enough to play remain firmly stuck on the phone.

Furthermore, these songs cannot be deleted by swiping left to reveal a delete button.

share|improve this question
add comment

4 Answers

I had the same exact problem. Ended up being that the song had not cpletely finished being downloaded to the phone, so it could be deleted. Go into settings and tell it to display all music again. Then go back to each song and click the cloud icon to download again. After each song downloads you will have the ability to swipe and delete, just like all of your other songs. I'm running ios7 too, so I'm sure this is your problem too.

share|improve this answer
    
That got rid of all the ones that I hadn't played. Songs I was foolish enough to play are still there. –  Gareth Simpson Sep 21 '13 at 19:13
2  
These songs have been downloaded to your iPhone, so you need to delete them - swipe the song(s) you want to delete to the left, and click "delete". –  Rene Larsen Sep 22 '13 at 16:29
2  
@GarethSimpson Further, go into Settings > iTunes & App Store, and ensure Automatic Downloads > Music is turned off. This will prevent future purchases by your family members from showing up on your phone. With these two settings off (and previously-played unwanted songs deleted), only songs you sync to your phone should appear. –  Dan J Sep 24 '13 at 16:34
    
You can't swipe these songs left to get the delete button. I can swipe all the other songs on the phone and delete them, but not the two purchased songs that I happened to play. –  Gareth Simpson Sep 27 '13 at 6:26
add comment

iPhones can’t stream music directly from iCloud, therefore all music you at some point played on your iPhone has been downloaded to your iPhone.

In order to delete a track, you can go into the song view and swipe the song to the left – a Delete button should appear, allowing you to delete the track from your phone.

share|improve this answer
    
Alas for these particular songs, the delete button does not appear. It does appear for all the regular songs on the phone. –  Gareth Simpson Sep 27 '13 at 6:27
add comment

One tip that has not been shown in answers thus far is to restart the music app after making the changes to settings. It seems that some residual setting is keeping your music visible and not allowing your settings to be used properly. Please check out the link here which pretty much summarises the same steps as answers already provided, but with pics, and shows where and how to restart the Music app. Also note, that the steps to swipe to delete the music need to be made while the show all music option is enabled, then you can disable it after you have removed them.

share|improve this answer
    
Thanks! The link you provided solved my problem. I turned Show All Music off, deleted all of my music from Usage, turned Show All Music on, then went through the Music app and swipe-deleted anything that was left. Afterwards, my library was completely empty, so I re-synced with iTunes and left Show All Music off. Thanks! –  Bill Dec 3 '13 at 18:36
add comment

You can always go to General Settings->Usage->Music delete all music from your phone from there and then re-sync only your playlist. After that disable the show all music setting and it should be fine.

Are you an iTunes match subscriber? If yes then in order to delete individual songs you also have to disable it first. Note that songs that you have listened through download but not explicitly downloaded (they still show a cloud button when show all music is enabled) are un-deletable (but will go away if you scrap the whole library).

share|improve this answer
    
I tried deleting all music from Usage and then re-syncing - the tracks were still there. I'm not an iTunes Match subscriber. –  Bill Dec 3 '13 at 14:10
add comment

protected by Community Oct 3 '13 at 10:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.