Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running an iPad 2 on iOS7.

I have 3 iPad 2 and an iPad mini. All running iOS7. On all of the devices, I access a site which has a 'remember me' cookie to save me having to log in again. This works fine on all devices except for one iPad 2. I have gone through all the safari settings and they match the other devices. I'm stuck now. What is the problem? It happened on iOS6 as well. The cookie appears to get deleted when I turn the ipad off and then back on.

I cleared the cookies and data in case that was the problem, but it still doesn't remember on this device.

safari security settings

share|improve this question
Is the time and date correct on the iPad 2? – Ashley Sep 26 '13 at 19:58

Make sure safari is not running in "private" mode. Open Safari, tap on the multiple tabs icon (should be furthest to right), and make sure private is not highlighted.

share|improve this answer

Could you check that your unknown web server, let's name it X web server for clarity, didn't put in place a security function to avoid your account to be stolen along the following scheme:

  1. X web server stores who and from which software, OS and location john is connecting from within a session cookie.
  2. If john connects with the same identification as the last presented one his access is granted.
  3. If john connects with a new identification, and john isn't connected elsewhere, then his access is granted and his cookie updated, else if john is already connected with another identification, then this is an attempt to steal john identification and this access is denied, and the used cookie (presumably stolen) is deleted.
share|improve this answer

I just solved this problem on my iPad.... Go to the passwords and auto fill option... (2nd line down in your screen shot above) and select remember passwords and the auto fill option.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.