Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I would like to know how to permanently disable the ALT key. I have a problem where by the computer is acting like the ALT key is pressed down. Every time I type I get strange characters.

I have tried going into the keyboard preferences and disabling the option key but that don't seem to be working. I disabled the ALT key in the past this way and it worked. When I open the keyboard viewer its showing the ALT key as being pressed down.

This is a 2011 Macbook Air. I can't afford a repair at the moment. Was hoping to take this into hospital with me today. Got to have chemo. But all morning I've been stuck on trying to disable it.

Any help is much appreciated.

share|improve this question

2 Answers 2

You could also have tried using a private.xml like this with KeyRemap4MacBook:

<?xml version="1.0"?>
<root>
  <item>
    <name>test</name>
    <identifier>test</identifier>
    <autogen>__KeyToKey__ KeyCode::OPTION_L, KeyCode::VK_NONE</autogen>
    <!--<autogen>__KeyToKey__ KeyCode::OPTION_R, KeyCode::VK_NONE</autogen>-->>
  </item>
</root>

System Preferences also allows disabling modifier keys, but there is no way disable the left and right modifier keys separately:

share|improve this answer

It seems that because the ALT key was stuck when disabling it, it had no effect. So, I bashed the keys and ran my fingers over them frantically and it unstuck the ALT key. I then went in and disabled it, and all is working fine.

Sometimes we have to go back to caveman tactics to solve these technological problems. If it don't work, bash it with the club.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.