Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently my Downloads folder has become read-only. This prevents Safari form saving any file amongst other annoyances.

As you can see from the below image the folder is read-only but I have plenty of disk space.

Downloads Folder

As you can see in the Info window it not locked. I am logged in as a user with admin rights etc, etc...

get Info

share|improve this question
Are you unable to change it back? Or are you just curious as to how it got changed? – LessPop_MoreFizz Sep 1 '10 at 22:25
what do you mean by lock? you can't click on lock icon and enter your password to unlock it? – Am1rr3zA Sep 8 '10 at 11:51
up vote 4 down vote accepted

You didn't specify that you can't change it back using the Info GUI, but I'm assuming that to be the case, since it wouldn't really be an issue otherwise.

A fix to try would be to change the permissions from the command line:

  1. Open
  2. Enter cd ~
  3. Enter sudo chmod +w Downloads
share|improve this answer
This solved the issue. – rjstelling Sep 10 '10 at 11:45

I suspect that you might have run an application directly from the Downloads directory, and that app has made the directory which it resides in ReadOnly to prevent any changes being made to it?

share|improve this answer
+1 for actually trying to answer the stated question! – mkoistinen Sep 10 '10 at 22:00

Silly question, but have you tried running Repair Disk Permissions from Disk Utility?

share|improve this answer
+1 for not making the poor guy use the terminal. – Agos Sep 8 '10 at 16:22
I believe Disk Permissions only affects things in the system-wide folders. I don't think any Users items are in the manifest, IIRC. – Andrew Vit Sep 2 '11 at 3:28

If you want to use the Finder to fix this;

  • In the Get Info window on that folder click to the lock in the very bottom right of the window to unlock the permissions. It will ask for your username and password.
  • Change the value beside your name (the one that says (Me)) to Read and Write from Read Only.

As to why this occurred - it could be many things; a badly behaved installer, a mistyped command or something else that isn't easy to see after the fact.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.