Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After a while being inactive with the mouse or keyboard, the macbook will dim my screen to save battery. I know I can expand the delay before it will dim in the system preferences, but are there any way of automatically disable it when watching video?

It's quite annoying having to touch the mouse every few minutes when watching a movie...

share|improve this question
    
What kind of video are you talking about (.avi or web)? Using Quicktime, if I put the movie in fullscreen, it no longer dim the screen. I haven't tested with other player. –  Loïc Wolff Sep 1 '10 at 21:25
    
The video that nudged me into writing this question, was the keynote published yesterday. I would guess that it used Quicktime? –  Vegar Sep 2 '10 at 16:20

3 Answers 3

up vote 9 down vote accepted

You could use a software like Caffeine to easily achieve your need :

Caffeine is a tiny program that puts an icon in the right side of your menu bar. Click it to prevent your Mac from automatically going to sleep, dimming the screen or starting screen savers. Click it again to go back. Right-click (or ⌘-click) the icon to show the menu.

share|improve this answer
    
I think I liked this one better. Will try for a while. Thanks ;-) –  Vegar Sep 1 '10 at 22:10
    
+1 I downloaded this app (if you can call it that) last night. Its pretty nifty. –  Nippysaurus Sep 2 '10 at 1:17

Depends how you use your laptop when you are watching the movie:)

You can adjust settings separately for Power adapter or Battery

system preferences>Energy Saver>Put the display(s) to sleep when the computer is inactive for... But make sure in Options section>other Options uncheck box "Automatically reduce the brightness of display before display sleep"

Or use caffeine software:)

share|improve this answer

Jiggler

Jiggler will "jiggle" the mouse transparently to stop dimming or other "sleep" actions. No installation, no ktext loading. Just a little jiggle every 20 sec or so.

I find it absolutely indespensible for watching Hulu movies, videos, or any other action where the screen should stay lit, but I don't want to tinker with the energy saver settings.

Jiggler

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.