Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm running an Automator Workflow that searches a provided directory, and then does a standard Filter Finder Items in order to make sure it's only going to be working with aliases.

Spotlight failed to find the file named "NUCLEUS SOUNDLAB Pantheon III.rfl." Please make sure privacy has not been enabled for this file in System Preferences. (-212)

The files being processed are on an external HD mounted over Firewire 800. I definitely do not have any privacy settings in spotlight at all.

Since it appears that the Spotlight index may be hosed and not working, I have been scouring for ways to force it to reindex the specific directory containing the file it's complaining about. Thus far, all attempts have failed:

  • Tried adding the HD to and removing it from privacy, no indexing occurred.
  • Tried using mdutil at the command line, no indexing occurred.
  • Tried removing all .spotlight references and reindexing, no indexing occurred.
  • Tried unmounting/remounting and rebooting, no change.

I'm at a loss as to what else to do. If I remove the "offending" file from the directory being searched in the workflow, it STILL throws the error on it - even if it's moved to a completely different volume and is very clearly NOT listed in the automator results of the task that succeeded prior to the Filter Finder Items task.

How can I get past this issue?

share|improve this question
    
Does it work outside the Automator ? –  Buscar웃 Sep 16 '13 at 8:00
    
What format is the external HD? I think certain formats don't work with Spotlight, eg possibly NTFS, although I'm not certain about this... –  Ashley Sep 16 '13 at 9:27
    
Could it be something to do with the file's owner and permissions (especially if the drive has also been used on another Mac)? Have you tried (re)setting the permissions on the offending file and the directory it resides in? –  M K Sep 16 '13 at 9:38
    
Is there really a period at the end of the name? –  beroe Sep 16 '13 at 13:05
    
Spotlight is able to find the file no problem outside of Automator. The drive is not NTFS, it's standard Mac OS Extended, Journaled. The filename does NOT have a period at the end, that's the way the error is written in Automator. –  Jonathan van Clute Sep 16 '13 at 15:30
add comment

1 Answer 1

What happens if you try in terminal.app (change /Search/Directory/ to yours):

mdfind -onlyin /Search/Directory/ kMDItemFSName == "\"NUCLEUS SOUNDLAB Pantheon III.rfl\""

Or in applescript editor.

    set searchPath to "/Search/Directory/"

    set this_item to "/Users/USERNAME/Desktop/NUCLEUS SOUNDLAB Pantheon III.rfl"

    set theFileName to "\\\"" & (do shell script "basename " & quoted form of (POSIX path of (this_item))) & "\\\"" as string

--set theFileName to quoted form of (do shell script "basename " & quoted form of (POSIX path of (this_item))) as string

  set theOrigFilePath to paragraphs of (do shell script "mdfind -onlyin " & searchPath & " kMDItemFSName == \"" & theFileName & "\"")
share|improve this answer
    
It just returned me the path of the file... so I guess it worked? Js-iMac:~ J$ mdfind -onlyin /Volumes/Audio\ HD\ 2/Refills/ kMDItemFSName == "\"NUCLEUS SOUNDLAB Pantheon III.rfl\"" /Volumes/Audio HD 2/Refills/Nucleus Sound Lab/Pantheon III/NUCLEUS SOUNDLAB Pantheon III.rfl –  Jonathan van Clute Sep 21 '13 at 1:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.