Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to get AVIDemux set up with the X264 codec using this tutorial. The following is what goes down when I get to the ./configure --enable-mp4-output command

Thomas-Phillipss-MacBook:x264 tomdabomb2u$ sudo ./configure --enable-mp4-output
Password:
Unknown option --enable-mp4-output, ignored
Found no assembler
Minimum version is yasm-0.6.2
If you really want to compile without asm, configure with --disable-asm.

So I tried it.

Thomas-Phillipss-MacBook:x264 tomdabomb2u$ sudo ./configure --enable-mp4-output --disable-asm
Unknown option --enable-mp4-output, ignored
Warning: gpac is too old, update to 2007-06-21 UTC or later
Platform:   X86_64
System:     MACOSX
asm:        no
avs:        no
lavf:       no
ffms:       no
gpac:       no
pthread:    yes
filters:    crop select_every
debug:      no
gprof:      no
PIC:        no
shared:     no
visualize:  no
bit depth:  8

You can run 'make' or 'make fprofiled' now.

I issued make, and then Thomas-Phillipss-MacBook:x264 tomdabomb2u$ ./x264 -v -q 20 -o foreman.mp4 foreman_part_qcif.yuv 176x144. And as expected, the results are:

x264 [error]: not compiled with MP4 output support

So I'm stuck. Any ideas?

share|improve this question

1 Answer 1

That's a pretty old tutorial. Try this one (linked from the official Avidemux site).

share|improve this answer
    
The tutorial you've linked to doesn't mention this issue - are you expecting it to fix something specifically or is it just a guess? –  PandaWood Jan 26 '11 at 9:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.