Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

If I have OS X display the time in the menu bar with blinking separators, the seem to blink inconsistently. I've taken a 32 second video of the effect. It's happening on two of my MacBook Airs, 13" Mid 2011 model. Running MacOSX 10.8.4. One is used at work and the other is my personal machine.

I know that this is a rather small issue but I'm still very curious on what might be causing this problem.

Update

Looks like it's fixed in Mavericks!

share|improve this question
2  
Happens here as well, but I use Day-O usually which doesn't blink anyway. But the disappearing separators seem to relate to other menulets updating at the same time (at least it looked like that to me), let's see whether somebody comes up with a conclusive answer. –  patrix Sep 9 '13 at 5:06
1  
Try to boot in safe mode and see if it still occurs. That is one of the way to know if it’s OS related issues, or simply caused by third party apps. –  sayzlim Sep 26 '13 at 18:04
1  
Have you tried resetting the menu bar? Open terminal and type killall -KILL SystemUIServer and see if that fixes it for you. –  Danijel J Oct 3 '13 at 6:34
1  
I have tried safe mode and resetting the menu bar but the problem is still there –  wyred Oct 3 '13 at 8:10
    
Do you have access to any other non-mac-airs in which you see this? –  Cawas Oct 5 '13 at 10:28

2 Answers 2

up vote 4 down vote accepted
+50

Some thoughts about how to track this down:

  1. In System Preferences > Language & Text > Region, do you have any unusual settings? (Some of these influence the formatting of the clock... from the video, you have the same settings as me, but I wonder if you have anything unusual here that perhaps Apple haven't tested too well?)

  2. Is there any pattern to the absence / presence of the separators? Eg, from your video, I see they are absent at 46, 47 and 48 seconds: is this true for every minute? (In which case, perhaps the cause of this might be some logic bug in the code that determines whether the separators should be shown for a given number of seconds.)

  3. I believe the SystemUIServer process controls many of the icons on the menu bar, including the clock. If you use Activity Monitor to quit it, it will quickly relaunch, but you'll get some insight into what that process is doing.

Some thoughts:

  • Is SystemUIServer perhaps using a lot of CPU?

  • Try removing any non-Apple menu bar icons for the moment (by quitting the appropriate apps), and see if the issue goes away. I suggest this because: even if SystemUIServer isn't using much CPU (and the system CPU load is low), I suspect that if one of the menu icons it controls blocks (that is: performs some system call which doesn't immediately return, perhaps because it is waiting for some data), then the updates of the clock might be paused.

After discussion below, seems that unfortunately none of this has helped to isolate the issue. The only remaining possibility I can think of is that you've run into an Apple bug... in which case, you might consider reporting it at bugreport.apple.com. (I have a paid developer account, but I believe that isn't required to report bugs there.)

share|improve this answer
    
1. Nope, I haven't changed them to anything unusual. On my personal machine, I have chosen Japan region and on my work machine, it's in the Singapore region. 2. It appears to be random. There are also cases where it will appear just for a split second and disappear. 3. SystemUIServer is hovering around 0.3~0.4 as I observed the seperators. My CPU is 90+% idle when this problem occurs. I removed MenuMeters, quit Skype and Dropbox. So the only icons left are wifi, volume, keyboard language, battery, the clock, spotlight and finally the notification center. Problem still exists. –  wyred Oct 10 '13 at 5:57
2  
Sorry if something in the answer didn't make sense, @Buscar웃. Thanks for the replies, wyred. Given you've reduced the icons down to just Apple-provided ones, the only remaining possibility I can think of is that you've run into an Apple bug -- sorry to hear that. I'll edit my answer with a little more thought, for what it's worth. –  Ashley Oct 10 '13 at 11:19

Maybe your system is going unresponsive between times. According to this book,

if the colon stops blinking, you’ll know your Mac is frozen and you can restart it.

So, normal blinking says that your mac is faster and if it is slowing down, you may be running some expensive operation running. I experience this whenever I run Photoshop.

share|improve this answer
3  
I assume that there are other ways to detect a frozen Mac than non-blinking separators :-) –  patrix Oct 9 '13 at 17:38
    
@patrix Yes, like the fact that it's frozen. –  JJ56 Oct 21 '13 at 1:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.