Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After the slew of updates this week I'm no longer able to backup either my iPhone 4 or iPad. There are two errors:

"iTunes was unable to load data class information from Sync Services. Reconnect or try again later"

and

"iTunes could not back up the iPhone "Lee Hinde's iPhone" because the backup session failed."

Probably not coincidentally the existing backups don't show up in iTunes (preferences/devices).

My searching on these errors indicates they mostly seem to happen to Windows users and I'm on Mac 10.6.6.

Synching actually works. Odd. I.e., if I update an app on either device or the Mac, they are transferred as they should. It's the backup that's not happening.

I also updated XCode and the one similar issue I saw on Twitter was from a developer, so I'm leaning towards blaming XCode.

Did a Repair Disk Permissions.

Any tips appreciated.

share|improve this question
1  
Remove iTunes and reinstall it. I'd go with AppCleaner to make sure it's completely cleared out. –  user479 Mar 13 '11 at 1:34
    
really. Can you describe the rebuild process? I mean, what will I have to do to get things going again? –  Lee Hinde Mar 15 '11 at 6:16
2  
Deleting/Reinstalling iTunes worked. Thanks very much. –  Lee Hinde Mar 15 '11 at 7:00
    
Glad it worked. –  user479 Mar 15 '11 at 22:59
add comment

1 Answer

up vote 0 down vote accepted

I would try manually checking the backups folder(username/Library/Application Support/Mobilesync)and then deleting anything in there. That error message makes me think Xcode but you could try resetting Sync History from preferences in iSync and resetting the SyncServices folder as per http://support.apple.com/kb/ts1627 . Doing that will wipe sync settings for your iPhone so you will have to re-check the information you want to sync in iTunes. I am running Xcode 4 on 10.6.7 and I have not run into this issue. Hopefully this resolves the issue, let me know if this helps. Also as per the last suggestion I would recommend following the instruction on the apple support site for reinstalling iTunes @ http://support.apple.com/kb/ht1224

share|improve this answer
    
Thank you. I'll talke a look at these links. –  Lee Hinde Mar 14 '11 at 4:33
    
What's not clear from the kb on SyncService reset is if my MobileMe setting get hammered; I would assume so. All that is working now. –  Lee Hinde Mar 14 '11 at 4:36
    
I bit the bullet and reset sync services; no change. –  Lee Hinde Mar 14 '11 at 4:58
    
Thanks for the link on how to reinstall iTunes. That was the fix. –  Lee Hinde Mar 15 '11 at 7:00
    
Great to hear, reinstalling has fixed soo many problems I have run across –  Dswabster Mar 15 '11 at 8:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.