Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For some reason, my MacBook Air 13inch (Mid 2012) 2 GHz Intel Core i7 OS X 10.8.4 will fail to connect to my Siemens SE567 ADSL Modem when WiFi security is enabled on it. It throws the following error message:

enter image description here

Every other device in the house will connect which includes:

  • An older MacBook Air
  • 2013 Mac Mini
  • 2 iPhone 5s
  • iPad Mini
  • iPad 1st gen
  • And an Apple TV

I've played around with all the settings, deleted network profiles, plists, reset the p ram and still get the error. Error only occurs when WiFi has security enabled.

Some more info about my system's WiFi:

Software Versions:
  CoreWLAN: 3.3 (330.15)
  CoreWLANKit:  2.0.2 (202.10)
  Menu Extra:   8.1 (810.9)
  configd plug-in:  8.4 (840.22.1)
  System Information:   8.3 (830.5)
  IO80211 Family:   5.3 (530.4)
  Diagnostics:  2.0 (200.24)
  AirPort Utility:  6.3.1 (631.4)
  Interfaces:
en0:
  Card Type:    AirPort Extreme  (0x14E4, 0xE9)
  Firmware Version: Broadcom BCM43xx 1.0 (5.106.98.100.17)
  MAC Address:  94:94:26:00:29:d0
  Locale:   FCC
  Country Code: X0
  Supported PHY Modes:  802.11 a/b/g/n
  Supported Channels:   1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165
  Wake On Wireless: Supported
  AirDrop:  Supported
  Status:   Connected
  Current Network Information:
Wifi:
  PHY Mode: 802.11g
  BSSID:    c0:d0:44:54:50:20
  Channel:  11
  Country Code: X0
  Network Type: Infrastructure
  Security: WPA Personal
  Signal / Noise:   -41 dBm / -92 dBm
  Transmit Rate:    54
  Other Local Wi-Fi Networks:
The fastnet:
  PHY Mode: 802.11g
  BSSID:    80:a1:d7:31:f1:b1
  Channel:  6
  Network Type: Infrastructure
  Security: WPA/WPA2 Personal
  Signal / Noise:   -86 dBm / -92 dBm
share|improve this question
    
Country Code: X0 is the problem? –  jnthnclrk Sep 4 '13 at 18:25
    
What should it be? –  jnthnclrk Sep 4 '13 at 18:29
    
look at the wifi profile of the other units that are working and compare –  Buscar웃 Sep 4 '13 at 18:31
    
I'm in Barbados. –  jnthnclrk Sep 4 '13 at 19:29
    
Just checked another MacBook Air that will connect and country codes are the same XO. –  jnthnclrk Sep 4 '13 at 19:30

1 Answer 1

I have done some in depth analysis for the same error on my MBA.

Basically there seems to be a MBA software problem somewhere in the Airport application.

In my case it looses the last digit of the Network Name (SSID) and then it claims it can not find it (what a surprise).

Then it issues the generic Connection time out Error.

Here is what it looks in my Console:

enter image description here

The actual name is Eurona900850808-81 as shown in the WiFi scan.

I would check the Console report on your computer to see what is going on.

If you need help how to get the report on your computer let me know.

I have been able to partially overcome this issue by disabling the Auto Join, and Auto remember networks.

share|improve this answer
    
Thanks! I will go back and look more closely at the Console. –  jnthnclrk Sep 15 '13 at 14:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.