Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to install the Solarized color scheme for my terminal on 10.8.4 Mountain Lion. I downloaded the .terminal files from https://github.com/tomislav/osx-terminal.app-colors-solarized and followed the instructions in the README which said:

OS X 10.7 Lion: Double click to install or import into Terminal.app preferences.
OS X 10.8 Mountain Lion: Import into Terminal.app preferences.

I declared the terminal as xterm-256color: Settings

But the Terminal looks like this: Terminal

What can I do so that the all the colors in the Solarized theme show up? You can see in my second screenshot that I ran ls and the directories aren't colored properly.

share|improve this question
1  
I'll clean up some text. What exactly isn't correct about these pictures? Please edit in exactly what you want to see differently or why the settings you have shown us are incorrect. –  bmike Aug 29 '13 at 1:20
    
The pictures weren't showing up, so I edited it to fix that. –  theconsultingthief Aug 29 '13 at 2:04
    
What is your prompt? and are you expecting ls output to be in colour? –  Mark Aug 30 '13 at 9:36
    
Mark, yes, I was expecting ls to color directories and executables in different colors similar to how Linux OSes do it. –  theconsultingthief Aug 31 '13 at 3:06

1 Answer 1

The bright green, yellow, blue, and cyan foreground colors seem to be almost the same as the default foreground color:

Or if you were expecting the themes to add colors to new places, they don't. They are Terminal settings files just change some of the settings that can also be changed from Terminal's preferences. You can make ls use colors with something like export CLICOLOR= LSCOLORS=dxfxcxdxbxegedabagacad.

share|improve this answer
    
I expected it to use the full range of colors shown, some for text color for certain commands. What is the point of the theme if it comes with all those colors and only uses two? Also, where exactly do I put export CLICOLOR= LSCOLORS=dxfxcxdxbxegedabagacad? –  theconsultingthief Aug 29 '13 at 20:49
    
It does use all hues for the non-bright colors, but you could try unchecking "Use bright colors for bold text" or copying the non-bright colors over the bright colors. If you use bash, put the export command in ~/.bashrc and add . ~/.bashrc to ~/.bash_profile. See this answer. –  ؘؘؘ Aug 30 '13 at 6:11
    
Thank you! This did it for me. Out of curiosity, why does adding the export to ~/.bash_profile not work, if, as the other post says, Terminal reads ~/.bash_profile on startup? I tried this, and it didn't work, so I put the export in ~/.bashrc like the other post explained. Also I like having my Terminal text be bold, so I did this in my settings, but the text in the Terminal is still not bold. Any ideas? Thanks! –  theconsultingthief Aug 31 '13 at 3:24
    
Adding the export command to ~/.bash_profile should work by default, but I don't know why it wouldn't. Your default font seems to be Monaco, which doesn't have a bold typeface. –  ؘؘؘ Aug 31 '13 at 5:42
    
Okay thanks! One last thing, I promise. The text colors look "off" in the terminal. For example, when in MacVim vs Terminal Vim. Why are the colors washed out/lighter in the terminal than they should be? –  theconsultingthief Aug 31 '13 at 6:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.