Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a local DNS server to resolve .dev as a testing domain on my machine, the resolution works fine and shows the proper answer through dig and ping and I can pull the home page instantly with curl.

The DNS server is my only configured name server in System Preferences acting as a forwarder to the corporate DNS servers.

However, in the browser the domain does not resolve properly. This appears to be because of my corporate proxy server, which is somehow taking priority in resolving over the local dns server. If I disable the proxy it resolves instantly.

I've excluded the .dev domain and localhost from the proxy in System Preferences, but still resolution is being done by the proxy server rather than my DNS server.

Can anyone help? How can I change the resolution order so that the proxy is second to my local DNS server?

share|improve this question
up vote 0 down vote accepted

It seems as though setting the search domains explicitly to be:


In System Preferences fixes the problem. For some reason otherwise gets suffixed as automatically. I'm not sure why as it is already a valid domain.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.