1

I'm trying to create a bootable USB for Windows using Disk Utility on OS X 10.8.4. Downloaded CentOS 6 for 32-bit and tried to use Disk Utility to create a bootable USB drive. This method failed with one of the two following errors:

  1. "Could not restore - Invalid argument"

  2. "Could not restore - error 254"

None of these solutions worked:

  • Convert the .iso to .dmg
  • Change permissions to rwx+ugo on image
  • Download image from another mirror
  • Use "minimal" image vs "full"
  • Change USB stick
  • Restore the "/Volumes" image (i.e. dragging from Desktop, not left panel of DiskUtility)

UNetbootin appears to burn the image to the USB, but testing on a Windows box shows that the disk image is missing.

For more on the Disk Utility errors:

http://forums.macrumors.com/showthread.php?t=1389072 https://discussions.apple.com/thread/1507263?start=0&tstart=0

2
  • I've been trying to make various bootable USB drives to use with my Mac on-and-off for a long, long time. Never quite figured out how to make it work. If you search (or just look at the "related" links to the right), you'll find lots of people with the same question ;D
    – iynque
    Dec 2, 2013 at 7:42
  • Could you describe the nature of the failure a bit more. Burning an ISO to a USB is pretty hard to mess up - as long as the ISO is correct, there's not much that can go wrong with dd bs=1m if=source of=/dev/disk1 that you won't see if the copy isn't perfect.
    – bmike
    Jan 4, 2014 at 17:20

3 Answers 3

2

did you try:

hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/target.iso

after that unmount using:

diskutil unmountDisk /dev/diskX

(X is the disknumber of your usb device)

Now just burn it using dd

sudo dd if=/path/to/target.img of=/dev/rdiskN bs=1m
0

Depending on the distro (not sure about centOS), sometimes just extracting the raw ISO to a freshly formatted flash drive in FAT32 will work. Could you try that and see if it works?

0

You can try to "burn" the ISO to the USB stick with the command-line utility dd. To do so, you can follow these instructions on the Ubuntu site.

Essentially you have to convert the .iso to a .img disk image and then copy it, byte by byte, on the device.

Not the answer you're looking for? Browse other questions tagged .